Home > Canon Ufr > Canon Ufr Ii Printer Driver For Linux Version 2.20

Canon Ufr Ii Printer Driver For Linux Version 2.20

To check the version of the printer driver, refer to "Checking the Driver Version" in the "Appendix". For details, refer to "Updating the Printer Driver" in "Installation". If you are using Fedora 19 or Ubuntu 14.10, specify "-P [PPD file path]" rather than "-m [PPD file name]" for the PPD file specifying option. Proceed according to the message. navigate here

If the driver version to be installed is the same as or newer than an installed driver, you can perform an overwrite installation. For information on printer models that require bi-directional communication, refer to the Readme file. Specify an absolute or relative path for [PPD file path]. For rpm packages: Enter the following command: # rpm -Uvh [file name of common module for CUPS drivers] For deb packages: Enter the following command: # dpkg -i [file name of

Normally, you can specify "/dev/usb/lp0" or "dev/usblp0". If the driver version to be installed is older than an installed driver, you can overwrite install a deb package, but you cannot overwrite install an rpm package. NOTE For the file name of each printer driver module, refer to "Installing the Printer Driver" of "Installation".

Restart CUPS. If you cannot print correctly, specify the device URI for [device file location]. Enter the following command: # /usr/sbin/lpadmin -x [Printer Name] Example: To delete the registration "CANON-iR105+": /usr/sbin/lpadmin -x CANON-iR105+ 3. Installing the Printer Driver The printer driver must be installed in order to print from Canon printers using Linux.

NOTE For the procedure for registering the printer (PPD), refer to Step 5 of "Installing the Printer Driver" of "Installation". In such cases, you can confirm [device file location] by executing the "/usr/lib/cups/backend/cnusb" command (in the case of 32-bit operating systems) with administrator privileges. Parallel Connection Enter the following lpadmin command: # /usr/sbin/lpadmin -p [Printer Name] -m [PPD file] -v parallel:/dev/lp0 -E USB Connection Enter the following lpadmin command: # /usr/sbin/lpadmin -p [Printer Name] -m https://wiki.debian.org/PrinterDriver/Canon/UFR-II To execute the installer, the computer you are using needs to be connected to an external network.

Install the UFR II/UFRII LT printer driver module. For rpm packages: Enter the following command: # /etc/init.d/cups restart For deb packages: Enter the following command: # /etc/init.d/cupsys restart NOTE Do not register the printer using the "lpadmin" command before In a LAN environment where IP addresses have been assigned, if the status of the printer cannot be displayed, the CUPS security settings must be changed. For rpm packages: Enter the following command: # /etc/init.d/cups restart For deb packages: Enter the following command: # /etc/init.d/cupsys restart When CUPS has finished restarting, proceed to "Printer Registration" and register

Example: For a network connection (IPv4), specify the absolute path for the PPD file, and register the name of the iRC3180 as "CANON-iRC3180" (IP address: 172.23.2.72). # /usr/sbin/lpadmin -p CANON-iRC3180 -P /usr/share/cups/model/CNCUPSIRC3180ZK.ppd -v lpd://172.23.2.72/CANON-iRC3180 -E NOTE You can install using the installer if you are using versions of the following distributions whose support periods are still valid. If the printer is already registered, re-register the printer after installation (see "Printer Registration"). NOTE The version of each module is indicated as "x.xx-x".

To check the version of the printer driver, refer to "Checking the Driver Version" in the "Appendix". check over here Before installing, CUPS must be installed and started on the operating system. Download the install files from the Canon web site. Version 2.20 or later common modules support combinations of version 2.20 or later LIPS, PostScript, LIPSLX, CARPS2, UFR II, and UFRII LT drivers.

Install the appropriate files by referring to the following. Manual Installation In the case of a manual installation, the files to be installed differ according to the environment you are using. Register the printer (PPD) with the print spooler. his comment is here Uninstall the existing printer driver, then install the new printer driver (see "Uninstalling the Printer Driver", "Installing the Printer Driver").

For rpm packages: Enter the following command: # rpm -ivh [file name of the UFR II/UFRII LT printer driver module] For deb packages: Enter the following command: # dpkg -i [file For details about the rpm command, enter "man rpm" with the terminal software, such as GNOME Terminal. 4. Install the common module for CUPS drivers.

For rpm packages: Enter the following command: # rpm -Uvh [file name of the UFR II/UFRII LT printer driver module] For deb packages: Enter the following command: # dpkg -i [file

Install the common module for CUPS drivers. Log in as 'root'. $ su 2. The following files are installed in 32-bit systems: "cndrvcups-common-x.xx-x.i386.rpm" : common module for CUPS drivers "cndrvcups-ufr2-uk-x.xx-x.i386.rpm" : UFR II/UFRII LT printer driver module The following files are installed in 64-bit systems: Add the set IP address to the following items in the cupsd.conf file (/etc/cups/cupsd.conf), and restart CUPS. Example:         :Order Deny,AllowDeny From AllAllow From 127.0.0.1Allow From XXX.XXX.XXX.XXX (Substitute

Installation Using the Installer Manual Installation Installation Using the Installer 1. For an rpm package, perform the installation after first uninstalling the installed driver. If you want to transfer Job Accounting configuration data after updating the printer driver, log in as "root" prior to updating, back up the files in the directory/etc/cngplp/accountand copy them back weblink Execute "install.sh" with root privileges.

Install the UFR II/UFRII LT printer driver module. For rpm packages: Enter the following command: # rpm -ivh [file name of common module for CUPS drivers] For deb packages: Enter the following command: # dpkg -i [file name of Start Linux, and log in as 'root'. $ su 2. Depending on the operating system you are using, you may need to use the above rpm package command to restart CUPS, even if the system you are using normally requires deb

Proceed to "Printer Registration" and register the printer. If UFR II/UFRII LT Printer Driver Version 1.40 or later is installed, you can update the existing driver without uninstalling it. Fedora Ubuntu If you are using a distribution other than those above, a message asking whether you want to continue the installation is displayed. Restart CUPS.

Version 2.20 or later common modules support combinations of version 2.20 or later LIPS, PostScript, LIPSLX, CARPS2, UFR II, and UFRII LT drivers. If so, use the following command.# service cups restart Printer Registration Register the printer (PPD) with the print spooler. NOTE For the PPD file corresponding to your printer, refer to the Readme file. Also make sure that printers can be added and enabled by various services, according to the security level that has been set.

If so, use the following command.# service cups restart 7. If you are connected via USB to a device that requires bi-directional communication, specify "cnusb" instead of "usb" in commands. You can confirm the device URI by executing the command "/usr/sbin/lpinfo -v". For rpm packages: Enter the following command: # rpm -qa | grep cndrv For deb packages: Enter the following command: # dpkg -l | grep cndrvcups NOTE For details about checking

If the printer (PPD) has already been registered, delete the printer's spooler registration. Linux_UFR II_PrinterDriver_VXXX.tar.gz * "VXXX" is the driver version. 2. The above command may be invalid in some operating systems.